Sporadic application freezes with 100% CPU load (1.0.6)

Report new issues and add information on existing ones.

Moderator: Kyete

Post Reply
Moritz Maxeiner
Posts: 7
Joined: Sat Mar 19, 2022 2:47 pm

Sporadic application freezes with 100% CPU load (1.0.6)

Post by Moritz Maxeiner » Fri Mar 25, 2022 3:01 pm

So this might be a bit of a weird issue: When running OWM 1.0.6 on Linux and using the landmass or region tool, sometimes the entire application just stops responding and freezes, with my performance monitor showing one core at 100% load from OWM.

I realize this is probably not enough information to find the cause / fix the issue and I'm of course willing to provide you with whatever information you may reasonably need.

For what it's worth, I'm running Funtoo Linux 1.4 (if you want I can try a distribution of your choice to try and reproduce the issue) on an Intel Core i7-8565U.

User avatar
Kanchou
Site Admin
Posts: 984
Joined: Mon Nov 10, 2014 2:23 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Kanchou » Wed Mar 30, 2022 10:59 am

Moritz Maxeiner wrote:
Fri Mar 25, 2022 3:01 pm
So this might be a bit of a weird issue: When running OWM 1.0.6 on Linux and using the landmass or region tool, sometimes the entire application just stops responding and freezes, with my performance monitor showing one core at 100% load from OWM.

I realize this is probably not enough information to find the cause / fix the issue and I'm of course willing to provide you with whatever information you may reasonably need.

For what it's worth, I'm running Funtoo Linux 1.4 (if you want I can try a distribution of your choice to try and reproduce the issue) on an Intel Core i7-8565U.
Thank you for the details! It's hard to try every distribution so this is very helpful feedback.

We do the bulk of our Linux regression testing with Ubuntu. I'd love to know if this is happening for you too in Ubuntu that way we could determine if it's hardware related or distro related.

We'll also try to add Funtoo to our testing (we do have light testing with other distros like Fedora, Mint, Mx and Devian).

- Alejandro
Alejandro S. Canosa
Three Minds Software

Moritz Maxeiner
Posts: 7
Joined: Sat Mar 19, 2022 2:47 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Moritz Maxeiner » Thu Mar 31, 2022 6:02 am

Hey Alejandro,

thank you for the feedback. Is there any specific version of Ubuntu you want me to try (14,16,18,20, assuming you're on LTS)?

With regards to Funtoo: It would be cool if you could, but as it's a source distribution (like Gentoo) where you have to compile everything, this might take an uneconomical amount of time for you. I just included it for reference I don't expect support for Funtoo. Usually anything that runs on other Linux distributions also runs on Funtoo - and if it doesn't that's usually a bug in Funtoo.

User avatar
Kanchou
Site Admin
Posts: 984
Joined: Mon Nov 10, 2014 2:23 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Kanchou » Thu Mar 31, 2022 4:33 pm

Moritz Maxeiner wrote:
Thu Mar 31, 2022 6:02 am
Hey Alejandro,

thank you for the feedback. Is there any specific version of Ubuntu you want me to try (14,16,18,20, assuming you're on LTS)?

With regards to Funtoo: It would be cool if you could, but as it's a source distribution (like Gentoo) where you have to compile everything, this might take an uneconomical amount of time for you. I just included it for reference I don't expect support for Funtoo. Usually anything that runs on other Linux distributions also runs on Funtoo - and if it doesn't that's usually a bug in Funtoo.
We do regression with both Ubuntu 18 and 20, so either would be awesome.

I can't think of anything that would make the issue specific to Funtoo .. unless it's something UI related with our custom build of wxWidgets.

Let us know what you see and we'll make sure to address it with our next release.

Thank you!

- Alejandro
Alejandro S. Canosa
Three Minds Software

Moritz Maxeiner
Posts: 7
Joined: Sat Mar 19, 2022 2:47 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Moritz Maxeiner » Wed Apr 06, 2022 12:48 pm

Alright, so I can no longer seem to reproduce this on my laptop (Funtoo) after some updates and it doesn't happen on my new, much beefier pc, where I've temporarily setup Ubuntu to test.

So for now, please consider this bug report invalid. Should I encounter something like it again, I'll collect more info.

stefanstr
Posts: 107
Joined: Sat Nov 15, 2014 5:25 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by stefanstr » Wed Apr 13, 2022 1:32 pm

I'm on an M1 MacBook Air, and the app freezes incredibly frequently during drawing. For some reason, the partition tool is especially flaky.

User avatar
Kanchou
Site Admin
Posts: 984
Joined: Mon Nov 10, 2014 2:23 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Kanchou » Tue Apr 26, 2022 5:35 pm

stefanstr wrote:
Wed Apr 13, 2022 1:32 pm
I'm on an M1 MacBook Air, and the app freezes incredibly frequently during drawing. For some reason, the partition tool is especially flaky.
Are you on Monterrey? Got a report the other day specifically on a MacBook air M1 that is the same as this. However, our M1 Mac Mini shows no issues.

What' resolution are you running?

Thank you!

- Alejandro
Alejandro S. Canosa
Three Minds Software

Sticktwig
Posts: 11
Joined: Tue Sep 20, 2022 1:40 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Sticktwig » Wed Oct 05, 2022 10:46 am

Poor Alejandro has many emails about my M1 Mac issues when creating terrains. This happens on both my M1 Mac Mini and MacBook Pro with the M1 Pro chip. Has been consistent across Monterey and Big Sur. Can't recall if I was still running Catalina when I first experienced the hangs.

Have you watched CPU usage in Activity Monitor? I've found when the CPU usage goes over 100% reported, that's when I've experienced OWM hanging with the spinning circle. Only rarely has it come back if left to process.

Happened once this morning. Happy to say OWM retrieved the work when it reopened the file after being force closed.

User avatar
Kanchou
Site Admin
Posts: 984
Joined: Mon Nov 10, 2014 2:23 pm

Re: Sporadic application freezes with 100% CPU load (1.0.6)

Post by Kanchou » Wed Oct 05, 2022 4:23 pm

Sticktwig wrote:
Wed Oct 05, 2022 10:46 am
Poor Alejandro has many emails about my M1 Mac issues when creating terrains. This happens on both my M1 Mac Mini and MacBook Pro with the M1 Pro chip. Has been consistent across Monterey and Big Sur. Can't recall if I was still running Catalina when I first experienced the hangs.

Have you watched CPU usage in Activity Monitor? I've found when the CPU usage goes over 100% reported, that's when I've experienced OWM hanging with the spinning circle. Only rarely has it come back if left to process.

Happened once this morning. Happy to say OWM retrieved the work when it reopened the file after being force closed.
It's very frustrating, but yeah for some reason in doesn't happen with the Mac Mini. I'm pretty sure it's an issue with Rosetta so we are working to have a native M1 build with our next release...

- Alejandro
Alejandro S. Canosa
Three Minds Software

Post Reply